What’s Vulnerable › Vulnerabilities
CVE-2022-2130: Cross-site Scripting (XSS) - Reflected in microweber/microweber
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.17.
Affected products
- microweber/microweber: before 1.2.17 — fixed in 1.2.17
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.17. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/dbd37dda91911360db23269897c737e0abae2c24
- https://huntr.dev/bounties/0142970a-5cb8-4dba-8bbc-4fa2f3bee65c
- https://github.com/microweber/microweber/commit/dbd37dda91911360db23269897c737e0abae2c24
- https://huntr.dev/bounties/0142970a-5cb8-4dba-8bbc-4fa2f3bee65c
Get alerted when CVE-2022-2130 or the next vulnerability affects your stack