What’s Vulnerable › Vulnerabilities
CVE-2022-2132
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-791
Description
A permissive list of allowed inputs flaw was found in DPDK. This issue allows a remote attacker to cause a denial of service triggered by sending a crafted Vhost header to DPDK.
Affected products
- Debian Linux: 10.0
- DPDK Data Plane Development Kit: before 19.11; from 20.0 before 20.11; from 21.0 before 21.11 — fixed in 19.11, 20.11, 21.11
- Fedoraproject Fedora: 36
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0
- RedHat Enterprise Linux Fast Datapath: 7.0, 8.0, 9.0
- Red Hat OpenShift Container Platform 4.18: 4.0
- nova_libvirt container provided by the Red Hat OpenStack Platform: 13.0
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: DPDK Data Plane Development Kit 19.11, 20.11, 21.11. Check the vendor advisory for mitigations.
References
- https://bugs.dpdk.org/show_bug.cgi?id=1031
- https://bugzilla.redhat.com/show_bug.cgi?id=2099475
- https://lists.debian.org/debian-lts-announce/2022/09/msg00000.html
- https://bugs.dpdk.org/show_bug.cgi?id=1031
- https://bugzilla.redhat.com/show_bug.cgi?id=2099475
- https://lists.debian.org/debian-lts-announce/2022/09/msg00000.html
Get alerted when CVE-2022-2132 or the next vulnerability affects your stack