What’s Vulnerable › Vulnerabilities
CVE-2022-21363
- Severity: medium (CVSS 6.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-19 · updated 2026-06-17
Description
Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J). Supported versions that are affected are 8.0.27 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.1 Base Score 6.6 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H).
Affected products
- Oracle Mysql Connectors: from 8.0.0 through 8.0.27
- quarkusio quarkus: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: quarkusio quarkus 2.7.0. Check the vendor advisory for mitigations.
References
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.oracle.com/security-alerts/cpujan2022.html
Get alerted when CVE-2022-21363 or the next vulnerability affects your stack