What’s Vulnerable › Vulnerabilities
CVE-2022-2144: Jquery Validation For Contact Form 7 < 5.3 - Arbitrary Options Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The Jquery Validation For Contact Form 7 WordPress plugin before 5.3 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change Blog options like default_role, users_can_register via a CSRF attack
Affected products
- Jquery Validation For Contact Form 7: before 5.3 — fixed in 5.3
How to fix
Upgrade to a fixed version: Jquery Validation For Contact Form 7 5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/419054d4-95e8-4f4a-b864-a98b3e18435a
- https://wpscan.com/vulnerability/419054d4-95e8-4f4a-b864-a98b3e18435a
Get alerted when CVE-2022-2144 or the next vulnerability affects your stack