What’s Vulnerable › Vulnerabilities
CVE-2022-2152: Duplicate Page and Post Plugin < 2.8 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Duplicate Page and Post WordPress plugin before 2.8 does not sanitise and escape its settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Duplicate Page and Post: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: Duplicate Page and Post 2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e972e2c5-0d56-4d2a-81cc-2b0dff750124
- https://wpscan.com/vulnerability/e972e2c5-0d56-4d2a-81cc-2b0dff750124
Get alerted when CVE-2022-2152 or the next vulnerability affects your stack