What’s Vulnerable › Vulnerabilities
CVE-2022-21642: Exposure of whisper participants in discourse
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-05 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open source platform for community discussion. In affected versions when composing a message from topic the composer user suggestions reveals whisper participants. The issue has been patched in stable version 2.7.13 and beta version 2.8.0.beta11. There is no workaround for this issue and users are advised to upgrade.
Affected products
- discourse: before 2.7.13; 2.8.0-beta1, 2.8.0-beta10, 2.8.0-beta2, 2.8.0-beta3, 2.8.0-beta4, 2.8.0-beta5 (+4) — fixed in 2.7.13
How to fix
Upgrade to a fixed version: discourse 2.7.13. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/702685b6a06ae45a544fc702027f1e4573d94aaa
- https://github.com/discourse/discourse/security/advisories/GHSA-mx3h-vc7w-r9c6
- https://github.com/discourse/discourse/commit/702685b6a06ae45a544fc702027f1e4573d94aaa
- https://github.com/discourse/discourse/security/advisories/GHSA-mx3h-vc7w-r9c6
Get alerted when CVE-2022-21642 or the next vulnerability affects your stack