What’s Vulnerable › Vulnerabilities
CVE-2022-21647: Deserialization of Untrusted Data in Codeigniter4
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 37.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-04 · updated 2026-06-17
- Weakness: CWE-502
Description
CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.
Affected products
- CodeIgniter4: from 4.0.0 before 4.1.6 — fixed in 4.1.6
How to fix
Upgrade to a fixed version: CodeIgniter4 4.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/codeigniter4/CodeIgniter4/commit/ce95ed5765256e2f09f3513e7d42790e0d6948f5
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-w6jr-wj64-mc9x
- https://github.com/codeigniter4/CodeIgniter4/commit/ce95ed5765256e2f09f3513e7d42790e0d6948f5
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-w6jr-wj64-mc9x
Get alerted when CVE-2022-21647 or the next vulnerability affects your stack