What’s Vulnerable › Vulnerabilities
CVE-2022-21648: Sandbox bypass in Latte templates
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Latte is an open source template engine for PHP. Versions since 2.8.0 Latte has included a template sandbox and in affected versions it has been found that a sandbox escape exists allowing for injection into web pages generated from Latte. This may lead to XSS attacks. The issue is fixed in the versions 2.8.8, 2.9.6 and 2.10.8. Users unable to upgrade should not accept template input from untrusted sources.
Affected products
- nette latte: from 2.8.0 before 2.8.8; from 2.9.0 before 2.9.6; from 2.10.0 before 2.10.8 — fixed in 2.10.8, 2.8.8, 2.9.6
How to fix
Upgrade to a fixed version: nette latte 2.10.8, 2.8.8, 2.9.6. Check the vendor advisory for mitigations.
References
- https://github.com/nette/latte/commit/9e1b4f7d70f7a9c3fa6753ffa7d7e450a3d4abb0
- https://github.com/nette/latte/security/advisories/GHSA-36m2-8rhx-f36j
- https://github.com/nette/latte/commit/9e1b4f7d70f7a9c3fa6753ffa7d7e450a3d4abb0
- https://github.com/nette/latte/security/advisories/GHSA-36m2-8rhx-f36j
Get alerted when CVE-2022-21648 or the next vulnerability affects your stack