What’s Vulnerable › Vulnerabilities
CVE-2022-21652: Insufficient Session Expiration in shopware
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-05 · updated 2026-06-17
- Weakness: CWE-613
Description
Shopware is an open source e-commerce software platform. In affected versions shopware would not invalidate a user session in the event of a password change. With version 5.7.7 the session validation was adjusted, so that sessions created prior to the latest password change of a customer account can't be used to login with said account. This also means, that upon a password change, all existing sessions for a given customer account are automatically considered invalid. There is no workaround for this issue.
Affected products
- shopware: from 5.7.3 before 5.7.7 — fixed in 5.7.7
How to fix
Upgrade to a fixed version: shopware 5.7.7. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022
- https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0
- https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6
- https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022
- https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0
- https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6
Get alerted when CVE-2022-21652 or the next vulnerability affects your stack