What’s Vulnerable › Vulnerabilities
CVE-2022-21653: Hash collision in typelevel jawn
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-05 · updated 2026-06-17
- Weakness: CWE-400
Description
Jawn is an open source JSON parser. Extenders of the `org.typelevel.jawn.SimpleFacade` and `org.typelevel.jawn.MutableFacade` who don't override `objectContext()` are vulnerable to a hash collision attack which may result in a denial of service. Most applications do not implement these traits directly, but inherit from a library. `jawn-parser-1.3.1` fixes this issue and users are advised to upgrade. For users unable to upgrade override `objectContext()` to use a collision-safe collection.
Affected products
- typelevel jawn: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: typelevel jawn 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/typelevel/jawn/pull/390
- https://github.com/typelevel/jawn/security/advisories/GHSA-vc89-hccf-rq55
- https://github.com/typelevel/jawn/pull/390
- https://github.com/typelevel/jawn/security/advisories/GHSA-vc89-hccf-rq55
Get alerted when CVE-2022-21653 or the next vulnerability affects your stack