What’s Vulnerable › Vulnerabilities
CVE-2022-21657: X.509 Extended Key Usage and Trust Purposes bypass in Envoy
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-22 · updated 2026-06-17
- Weakness: CWE-295
Description
Envoy is an open source edge and service proxy, designed for cloud-native applications. In affected versions Envoy does not restrict the set of certificates it accepts from the peer, either as a TLS client or a TLS server, to only those certificates that contain the necessary extendedKeyUsage (id-kp-serverAuth and id-kp-clientAuth, respectively). This means that a peer may present an e-mail certificate (e.g. id-kp-emailProtection), either as a leaf certificate or as a CA in the chain, and it will be accepted for TLS. This is particularly bad when combined with the issue described in pull request #630, in that it allows a Web PKI CA that is intended only for use with S/MIME, and thus exempted from audit or supervision, to issue TLS certificates that will be accepted by Envoy. As a result Envoy will trust upstream certificates that should not be trusted. There are no known workarounds to this issue. Users are advised to upgrade.
Affected products
- envoyproxy envoy: before 1.18.6; from 1.19.0 before 1.19.3; from 1.20.0 before 1.20.2 — fixed in 1.18.6, 1.19.3, 1.20.2
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.18.6, 1.19.3, 1.20.2. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/pull/630
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-837m-wjrv-vm5g
- https://github.com/envoyproxy/envoy/pull/630
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-837m-wjrv-vm5g
Get alerted when CVE-2022-21657 or the next vulnerability affects your stack