What’s Vulnerable › Vulnerabilities
CVE-2022-21659: Observable Response Discrepancy in Flask-AppBuilder
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-31 · updated 2026-06-17
- Weakness: CWE-203
Description
Flask-AppBuilder is an application development framework, built on top of the Flask web framework. In affected versions there exists a user enumeration vulnerability. This vulnerability allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in. Users are advised to upgrade to version 3.4.4 as soon as possible. There are no known workarounds for this issue.
Affected products
- dpgaspar Flask-AppBuilder: before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: dpgaspar Flask-AppBuilder 3.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/dpgaspar/Flask-AppBuilder/pull/1775
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-wfjw-w6pv-8p7f
- https://github.com/dpgaspar/Flask-AppBuilder/pull/1775
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-wfjw-w6pv-8p7f
Get alerted when CVE-2022-21659 or the next vulnerability affects your stack