What’s Vulnerable › Vulnerabilities
CVE-2022-21664: SQL injection in WordPress
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-06 · updated 2026-06-17
- Weakness: CWE-89
Description
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to lack of proper sanitization in one of the classes, there's potential for unintended SQL queries to be executed. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 4.1.34. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35
- WordPress: before 5.8.3 — fixed in 5.8.3
How to fix
Upgrade to a fixed version: WordPress 5.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/commit/c09ccfbc547d75b392dbccc1ef0b4442ccd3c957
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-jp3p-gw8h-6x86
- https://lists.debian.org/debian-lts-announce/2022/01/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CV4UNEC63UU5GEU47IIR4RMTZAHNEOJG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DM6XPH3JN6V4NF4WBOJTOXZIVE6VKKE3/
- https://wordpress.org/news/2022/01/wordpress-5-8-3-security-release/
- https://www.debian.org/security/2022/dsa-5039
- https://github.com/WordPress/wordpress-develop/commit/c09ccfbc547d75b392dbccc1ef0b4442ccd3c957
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-jp3p-gw8h-6x86
- https://lists.debian.org/debian-lts-announce/2022/01/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CV4UNEC63UU5GEU47IIR4RMTZAHNEOJG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DM6XPH3JN6V4NF4WBOJTOXZIVE6VKKE3/
Get alerted when CVE-2022-21664 or the next vulnerability affects your stack