What’s Vulnerable › Vulnerabilities
CVE-2022-21677: Group advanced search option may leak group and group's members visibility
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-14 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open source discussion platform. Discourse groups can be configured with varying visibility levels for the group as well as the group members. By default, a newly created group has its visibility set to public and the group's members visibility set to public as well. However, a group's visibility and the group's members visibility can be configured such that it is restricted to logged on users, members of the group or staff users. A vulnerability has been discovered in versions prior to 2.7.13 and 2.8.0.beta11 where the group advanced search option does not respect the group's visibility and members visibility level. As such, a group with restricted visibility or members visibility can be revealed through search with the right search option. This issue is patched in `stable` version 2.7.13, `beta` version 2.8.0.beta11, and `tests-passed` version 2.8.0.beta11 versions of Discourse. There are no workarounds aside from upgrading.
Affected products
- discourse: through 2.7.12; 2.8.0-beta1, 2.8.0-beta10, 2.8.0-beta2, 2.8.0-beta3, 2.8.0-beta4, 2.8.0-beta5 (+4)
References
- https://github.com/discourse/discourse/commit/fff8b98485561b12d070c0a8c39f4e503813ab44
- https://github.com/discourse/discourse/security/advisories/GHSA-768r-ppv4-5r27
- https://github.com/discourse/discourse/commit/fff8b98485561b12d070c0a8c39f4e503813ab44
- https://github.com/discourse/discourse/security/advisories/GHSA-768r-ppv4-5r27
Get alerted when CVE-2022-21677 or the next vulnerability affects your stack