What’s Vulnerable › Vulnerabilities
CVE-2022-21687: Command injection in gh-ost
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-20
Description
gh-ost is a triggerless online schema migration solution for MySQL. Versions prior to 1.1.3 are subject to an arbitrary file read vulnerability. The attacker must have access to the target host or trick an administrator into executing a malicious gh-ost command on a host running gh-ost, plus network access from host running gh-ost to the attack's malicious MySQL server. The `-database` parameter does not properly sanitize user input which can lead to arbitrary file reads.
Affected products
- GitHub Gh-Ost: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: GitHub Gh-Ost 1.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/github/gh-ost/commit/a91ab042de013cfd8fbb633763438932d9080d8f
- https://github.com/github/gh-ost/security/advisories/GHSA-rrp4-2xx3-mv29
- https://github.com/github/gh-ost/commit/a91ab042de013cfd8fbb633763438932d9080d8f
- https://github.com/github/gh-ost/security/advisories/GHSA-rrp4-2xx3-mv29
Get alerted when CVE-2022-21687 or the next vulnerability affects your stack