What’s Vulnerable › Vulnerabilities
CVE-2022-21697: SSRF vulnerability (requires authentication)
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-25 · updated 2026-06-17
- Weakness: CWE-918
Description
Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.
Affected products
- jupyterhub jupyter-server-proxy: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: jupyterhub jupyter-server-proxy 3.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/jupyterhub/jupyter-server-proxy/commit/fd31930bacd12188c448c886e0783529436b99eb
- https://github.com/jupyterhub/jupyter-server-proxy/compare/v3.2.0...v3.2.1.patch
- https://github.com/jupyterhub/jupyter-server-proxy/security/advisories/GHSA-gcv9-6737-pjqw
- https://github.com/jupyterhub/jupyter-server-proxy/commit/fd31930bacd12188c448c886e0783529436b99eb
- https://github.com/jupyterhub/jupyter-server-proxy/compare/v3.2.0...v3.2.1.patch
- https://github.com/jupyterhub/jupyter-server-proxy/security/advisories/GHSA-gcv9-6737-pjqw
Get alerted when CVE-2022-21697 or the next vulnerability affects your stack