What’s Vulnerable › Vulnerabilities
CVE-2022-21704: Incorrect Default Permissions in log4js-node
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-19 · updated 2026-06-17
- Weakness: CWE-276
Description
log4js-node is a port of log4js to node.js. In affected versions default file permissions for log files created by the file, fileSync and dateFile appenders are world-readable (in unix). This could cause problems if log files contain sensitive information. This would affect any users that have not supplied their own permissions for the files via the mode parameter in the config. Users are advised to update.
Affected products
- Debian Linux: 10.0
- Log4Js Project Log4Js: before 6.4.0 — fixed in 6.4.0
How to fix
Upgrade to a fixed version: Log4Js Project Log4Js 6.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/log4js-node/log4js-node/blob/v6.4.0/CHANGELOG.md#640
- https://github.com/log4js-node/log4js-node/pull/1141/commits/8042252861a1b65adb66931fdf702ead34fa9b76
- https://github.com/log4js-node/log4js-node/security/advisories/GHSA-82v2-mx6x-wq7q
- https://github.com/log4js-node/streamroller/pull/87
- https://lists.debian.org/debian-lts-announce/2022/12/msg00014.html
- https://github.com/log4js-node/log4js-node/blob/v6.4.0/CHANGELOG.md#640
- https://github.com/log4js-node/log4js-node/pull/1141/commits/8042252861a1b65adb66931fdf702ead34fa9b76
- https://github.com/log4js-node/log4js-node/security/advisories/GHSA-82v2-mx6x-wq7q
- https://github.com/log4js-node/streamroller/pull/87
- https://lists.debian.org/debian-lts-announce/2022/12/msg00014.html
Get alerted when CVE-2022-21704 or the next vulnerability affects your stack