What’s Vulnerable › Vulnerabilities
CVE-2022-21711: Out-of-bounds Read lead to application crashes or information leakage in ELF parsing.
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-125
Description
elfspirit is an ELF static analysis and injection framework that parses, manipulates, and camouflages ELF files. When analyzing the ELF file format in versions prior to 1.1, there is an out-of-bounds read bug, which can lead to application crashes or information leakage. By constructing a special format ELF file, the information of any address can be leaked. elfspirit version 1.1 contains a patch for this issue.
Affected products
- liyansong2018 elfspirit: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: liyansong2018 elfspirit 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/liyansong2018/elfspirit/commit/c5b0f5a9a24f2451bbeda4751d67633bc375e608
- https://github.com/liyansong2018/elfspirit/issues/1
- https://github.com/liyansong2018/elfspirit/security/advisories/GHSA-jr8h-2657-m68r
- https://github.com/liyansong2018/elfspirit/commit/c5b0f5a9a24f2451bbeda4751d67633bc375e608
- https://github.com/liyansong2018/elfspirit/issues/1
- https://github.com/liyansong2018/elfspirit/security/advisories/GHSA-jr8h-2657-m68r
Get alerted when CVE-2022-21711 or the next vulnerability affects your stack