What’s Vulnerable › Vulnerabilities
CVE-2022-21716: Buffer Overflow in Twisted
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-03 · updated 2026-06-17
- Weakness: CWE-120
Description
Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 22.2.0, Twisted SSH client and server implement is able to accept an infinite amount of data for the peer's SSH version identifier. This ends up with a buffer using all the available memory. The attach is a simple as `nc -rv localhost 22 < /dev/zero`. A patch is available in version 22.2.0. There are currently no known workarounds.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 35, 36
- Oracle Corporation Oracle HTTP Server: 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle ZFS Storage Appliance Kit: 8.8
- twisted: from 21.7.0 before 22.2.0 — fixed in 22.2.0
How to fix
Upgrade to a fixed version: twisted 22.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/twisted/twisted/commit/89c395ee794e85a9657b112c4351417850330ef9
- https://github.com/twisted/twisted/releases/tag/twisted-22.2.0
- https://github.com/twisted/twisted/security/advisories/GHSA-rv6r-3f5q-9rgx
- https://lists.debian.org/debian-lts-announce/2022/03/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7U6KYDTOLPICAVSR34G2WRYLFBD2YW5K/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GLKHA6WREIVAMBQD7KKWYHPHGGNKMAG6/
- https://security.gentoo.org/glsa/202301-02
- https://twistedmatrix.com/trac/ticket/10284
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://github.com/twisted/twisted/commit/89c395ee794e85a9657b112c4351417850330ef9
- https://github.com/twisted/twisted/releases/tag/twisted-22.2.0
- https://github.com/twisted/twisted/security/advisories/GHSA-rv6r-3f5q-9rgx
Get alerted when CVE-2022-21716 or the next vulnerability affects your stack