What’s Vulnerable › Vulnerabilities
CVE-2022-21719: Reflected XSS using reload button in GLPI
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a free asset and IT management software package. All GLPI versions prior to 9.5.7 are vulnerable to reflected cross-site scripting. Version 9.5.7 contains a patch for this issue. There are no known workarounds.
Affected products
- glpi-project glpi: before 9.5.7 — fixed in 9.5.7
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/e9b16bc8e9b61ebb2d35b96b9c71cd25c5af9e48
- https://github.com/glpi-project/glpi/releases/tag/9.5.7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-6cj4-g839-gj5j
- https://github.com/glpi-project/glpi/commit/e9b16bc8e9b61ebb2d35b96b9c71cd25c5af9e48
- https://github.com/glpi-project/glpi/releases/tag/9.5.7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-6cj4-g839-gj5j
Get alerted when CVE-2022-21719 or the next vulnerability affects your stack