What’s Vulnerable › Vulnerabilities
CVE-2022-2172: LinkWorth Plugin < 3.3.4 - Arbitrary Setting Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The LinkWorth WordPress plugin before 3.3.4 does not implement nonce checks, which could allow attackers to make a logged in admin change settings via a CSRF attack.
Affected products
- LinkWorth Plugin: before 3.3.4 — fixed in 3.3.4
How to fix
Upgrade to a fixed version: LinkWorth Plugin 3.3.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?new=2754739%40linkworth-wp-plugin&old=2750802%40linkworth-wp-plugin#file8
- https://wpscan.com/vulnerability/bfb6ed12-ae64-4075-9d0b-5620e998df74
- https://plugins.trac.wordpress.org/changeset?new=2754739%40linkworth-wp-plugin&old=2750802%40linkworth-wp-plugin#file8
- https://wpscan.com/vulnerability/bfb6ed12-ae64-4075-9d0b-5620e998df74
Get alerted when CVE-2022-2172 or the next vulnerability affects your stack