What’s Vulnerable › Vulnerabilities
CVE-2022-21720: SQL injection using custom CSS administration form in GLPI
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-28 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a free asset and IT management software package. Prior to version 9.5.7, an entity administrator is capable of retrieving normally inaccessible data via SQL injection. Version 9.5.7 contains a patch for this issue. As a workaround, disabling the `Entities` update right prevents exploitation of this vulnerability.
Affected products
- glpi-project glpi: before 9.5.7 — fixed in 9.5.7
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/5c3eee696b503fdf502f506b00d15cf5b324b326
- https://github.com/glpi-project/glpi/releases/tag/9.5.7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-5hg4-r64r-rf83
- https://github.com/glpi-project/glpi/commit/5c3eee696b503fdf502f506b00d15cf5b324b326
- https://github.com/glpi-project/glpi/releases/tag/9.5.7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-5hg4-r64r-rf83
Get alerted when CVE-2022-21720 or the next vulnerability affects your stack