What’s Vulnerable › Vulnerabilities
CVE-2022-21721: DOS Vulnerability in next.js
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-28 · updated 2026-06-17
Description
Next.js is a React framework. Starting with version 12.0.0 and prior to version 12.0.9, vulnerable code could allow a bad actor to trigger a denial of service attack for anyone using i18n functionality. In order to be affected by this CVE, one must use next start or a custom server and the built-in i18n support. Deployments on Vercel, along with similar environments where invalid requests are filtered before reaching Next.js, are not affected. A patch has been released, `next@12.0.9`, that mitigates this issue. As a workaround, one may ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until it becomes feasible to upgrade.
Affected products
- Next.js: from 12.0.0 before 12.0.9 — fixed in 12.0.9
How to fix
Upgrade to a fixed version: Next.js 12.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/pull/33503
- https://github.com/vercel/next.js/releases/tag/v12.0.9
- https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x
- https://github.com/vercel/next.js/pull/33503
- https://github.com/vercel/next.js/releases/tag/v12.0.9
- https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x
Get alerted when CVE-2022-21721 or the next vulnerability affects your stack