What’s Vulnerable › Vulnerabilities
CVE-2022-21724: Unchecked Class Instantiation when providing Plugin Classes
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-02 · updated 2026-06-17
- Weakness: CWE-665
Description
pgjdbc is the offical PostgreSQL JDBC Driver. A security hole was found in the jdbc driver for postgresql database while doing security research. The system using the postgresql library will be attacked when attacker control the jdbc url or properties. pgjdbc instantiates plugin instances based on class names provided via `authenticationPluginClassName`, `sslhostnameverifier`, `socketFactory`, `sslfactory`, `sslpasswordcallback` connection properties. However, the driver did not verify if the class implements the expected interface before instantiating the class. This can lead to code execution loaded via arbitrary classes. Users using plugins are advised to upgrade. There are no known workarounds for this issue.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 35
- Postgresql Jdbc Driver: before 42.2.25; from 42.3.0 before 42.3.2; 42.3.2-rc1 — fixed in 42.2.25, 42.3.2
- quarkusio quarkus: before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: Postgresql Jdbc Driver 42.2.25, 42.3.2; quarkusio quarkus 2.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/pgjdbc/pgjdbc/commit/f4d0ed69c0b3aae8531d83d6af4c57f22312c813
- https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-v7wg-cpwc-24m4
- https://lists.debian.org/debian-lts-announce/2022/05/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BVEO7BEFXPBVHSPYL3YKQWZI6DYXQLFS/
- https://security.netapp.com/advisory/ntap-20220311-0005/
- https://www.debian.org/security/2022/dsa-5196
- https://github.com/pgjdbc/pgjdbc/commit/f4d0ed69c0b3aae8531d83d6af4c57f22312c813
- https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-v7wg-cpwc-24m4
- https://lists.debian.org/debian-lts-announce/2022/05/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BVEO7BEFXPBVHSPYL3YKQWZI6DYXQLFS/
- https://security.netapp.com/advisory/ntap-20220311-0005/
- https://www.debian.org/security/2022/dsa-5196
Get alerted when CVE-2022-21724 or the next vulnerability affects your stack