What’s Vulnerable › Vulnerabilities
CVE-2022-2174: Cross-site Scripting (XSS) - Reflected in microweber/microweber
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.18.
Affected products
- microweber/microweber: before 1.2.18 — fixed in 1.2.18
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.18. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/c51285f791e48e536111cd57a9544ccbf7f33961
- https://huntr.dev/bounties/ac68e3fc-8cf1-4a62-90ee-95c4b2bad607
- https://github.com/microweber/microweber/commit/c51285f791e48e536111cd57a9544ccbf7f33961
- https://huntr.dev/bounties/ac68e3fc-8cf1-4a62-90ee-95c4b2bad607
Get alerted when CVE-2022-2174 or the next vulnerability affects your stack