What’s Vulnerable › Vulnerabilities
CVE-2022-2175: Buffer Over-read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-23 · updated 2026-10-08
- Weakness: CWE-126
Description
Buffer Over-read in GitHub repository vim/vim prior to 8.2.
Affected products
- Fedoraproject Fedora: 35, 36
- vim/vim: before 8.2.5148 — fixed in 8.2.5148
How to fix
Upgrade to a fixed version: vim/vim 8.2.5148. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/6046aded8da002b08d380db29de2ba0268b6616e
- https://huntr.dev/bounties/7f0481c2-8b57-4324-b47c-795d1ea67e55
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/6046aded8da002b08d380db29de2ba0268b6616e
- https://huntr.dev/bounties/7f0481c2-8b57-4324-b47c-795d1ea67e55
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2175 or the next vulnerability affects your stack