What’s Vulnerable › Vulnerabilities
CVE-2022-21797: Arbitrary Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-94
Description
The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 36, 37
- Joblib Project Joblib: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: Joblib Project Joblib 1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/joblib/joblib/commit/b90f10efeb670a2cc877fb88ebb3f2019189e059
- https://github.com/joblib/joblib/issues/1128
- https://github.com/joblib/joblib/pull/1321
- https://lists.debian.org/debian-lts-announce/2022/11/msg00020.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BVOMMW37OXZWU2EV5ONAAS462IQEHZOF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MJ5XTJS6OKJRRVXWFN5J67K3BYPEOBDF/
- https://security.gentoo.org/glsa/202401-01
- https://security.snyk.io/vuln/SNYK-PYTHON-JOBLIB-3027033
- https://github.com/joblib/joblib/commit/b90f10efeb670a2cc877fb88ebb3f2019189e059
- https://github.com/joblib/joblib/issues/1128
- https://github.com/joblib/joblib/pull/1321
Get alerted when CVE-2022-21797 or the next vulnerability affects your stack