What’s Vulnerable › Vulnerabilities
CVE-2022-2180: GREYD.SUITE < 1.2.7 - Unauthenticated File Upload to RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-434
Description
The GREYD.SUITE WordPress theme does not properly validate uploaded custom font packages, and does not perform any authorization or csrf checks, allowing an unauthenticated attacker to upload arbitrary files including php source files, leading to possible remote code execution (RCE).
Affected products
- greyd_suite: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: greyd_suite 1.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c330f92b-1e21-414f-b316-d5e97cb62bd1
- https://wpscan.com/vulnerability/c330f92b-1e21-414f-b316-d5e97cb62bd1
Get alerted when CVE-2022-2180 or the next vulnerability affects your stack