What’s Vulnerable › Vulnerabilities
CVE-2022-21802: Cross-site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The package grapesjs before 0.19.5 are vulnerable to Cross-site Scripting (XSS) due to an improper sanitization of the class name in Selector Manager.
Affected products
- grapesjs: before 0.19.5 — fixed in 0.19.5
How to fix
Upgrade to a fixed version: grapesjs 0.19.5. Check the vendor advisory for mitigations.
References
- https://github.com/artf/grapesjs/commit/13e85d152d486b968265c4b8017e8901e7d89ff3
- https://github.com/artf/grapesjs/issues/4411%23issuecomment-1167202709
- https://github.com/artf/grapesjs/releases/tag/v0.19.5
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2936781
- https://security.snyk.io/vuln/SNYK-JS-GRAPESJS-2935960
- https://github.com/artf/grapesjs/commit/13e85d152d486b968265c4b8017e8901e7d89ff3
- https://github.com/artf/grapesjs/issues/4411%23issuecomment-1167202709
- https://github.com/artf/grapesjs/releases/tag/v0.19.5
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2936781
- https://security.snyk.io/vuln/SNYK-JS-GRAPESJS-2935960
Get alerted when CVE-2022-21802 or the next vulnerability affects your stack