What’s Vulnerable › Vulnerabilities
CVE-2022-21827
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-26 · updated 2026-06-17
- Weakness: CWE-269
Description
An improper privilege vulnerability has been discovered in Citrix Gateway Plug-in for Windows (Citrix Secure Access for Windows) <21.9.1.2 what could allow an attacker who has gained local access to a computer with Citrix Gateway Plug-in installed, to corrupt or delete files as SYSTEM.
Affected products
- Citrix Gateway Plug-in for Windows: before 21.9.1.2 — fixed in 21.9.1.2
- Citrix Gateway Windows Plugin: Citrix Gateway Plug-in for Windows versions before 21.9.1.2
How to fix
Upgrade to a fixed version: Citrix Gateway Plug-in for Windows 21.9.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-21827 or the next vulnerability affects your stack