What’s Vulnerable › Vulnerabilities

CVE-2022-21829

Description

Concrete CMS Versions 9.0.0 through 9.0.2 and 8.5.7 and below can download zip files over HTTP and execute code from those zip files which could lead to an RCE. Fixed by enforcing ‘concrete_secure’ instead of ‘concrete’. Concrete now only makes requests over https even a request comes in via http. Concrete CMS security team ranked this 8 with CVSS v3.1 vector: AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H Credit goes to Anna for reporting HackerOne 1482520.

Affected products

How to fix

Upgrade to a fixed version: Concrete CMS 8.5.8, 9.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-21829 or the next vulnerability affects your stack