What’s Vulnerable › Vulnerabilities
CVE-2022-2183: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-23 · updated 2026-10-08
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 8.2.
Affected products
- Fedoraproject Fedora: 35, 36
- vim/vim: before 8.2.5151 — fixed in 8.2.5151
How to fix
Upgrade to a fixed version: vim/vim 8.2.5151. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/8eba2bd291b347e3008aa9e565652d51ad638cfa
- https://huntr.dev/bounties/d74ca3f9-380d-4c0a-b61c-11113cc98975
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/8eba2bd291b347e3008aa9e565652d51ad638cfa
- https://huntr.dev/bounties/d74ca3f9-380d-4c0a-b61c-11113cc98975
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2183 or the next vulnerability affects your stack