What’s Vulnerable › Vulnerabilities

CVE-2022-21831: Possible code injection vulnerability in Rails / Active Storage

Description

A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments.

Affected products

How to fix

Upgrade to a fixed version: rubyonrails Active Storage 5.2.6.3, 6.0.4.7, 6.1.4.7, 7.0.2.3; Rubygems Activestorage 5.2.6.3, 6.0.4.7, 6.1.4.7, 7.0.2.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-21831 or the next vulnerability affects your stack