What’s Vulnerable › Vulnerabilities
CVE-2022-2184: CAPTCHA 4WP < 7.1.0 - Local File Inclusion via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-22
Description
The CAPTCHA 4WP WordPress plugin before 7.1.0 lets user input reach a sensitive require_once call in one of its admin-side templates. This can be abused by attackers, via a Cross-Site Request Forgery attack to run arbitrary code on the server.
Affected products
- CAPTCHA 4WP: before 7.1.0 — fixed in 7.1.0
How to fix
Upgrade to a fixed version: CAPTCHA 4WP 7.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e777784f-5ba0-4966-be27-e0a0cbbfe056
- https://wpscan.com/vulnerability/e777784f-5ba0-4966-be27-e0a0cbbfe056
Get alerted when CVE-2022-2184 or the next vulnerability affects your stack