What’s Vulnerable › Vulnerabilities

CVE-2022-2185

Description

A critical issue has been discovered in GitLab affecting all versions starting from 14.0 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 where an authenticated user authorized to import projects could import a maliciously crafted project leading to remote code execution.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.10.5, 15.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2185 or the next vulnerability affects your stack