What’s Vulnerable › Vulnerabilities
CVE-2022-2186: Simple Post Notes < 1.7.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Simple Post Notes WordPress plugin before 1.7.6 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- BracketSpace Simple Post Notes: before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: BracketSpace Simple Post Notes 1.7.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b766103a-7f91-4d91-9f9c-bff4bfd53f57
- https://wpscan.com/vulnerability/b766103a-7f91-4d91-9f9c-bff4bfd53f57
Get alerted when CVE-2022-2186 or the next vulnerability affects your stack