What’s Vulnerable › Vulnerabilities
CVE-2022-21899: Windows Extensible Firmware Interface Security Feature Bypass Vulnerability
- Severity: medium (CVSS 4.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-11 · updated 2026-06-17
Description
Windows Extensible Firmware Interface Security Feature Bypass Vulnerability
Affected products
- Microsoft Windows 10 Version 1607: all versions
- Microsoft Windows 7: all versions
- Microsoft Windows 8.1: all versions
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows 10 Version 1507: from 10.0.10240.0 before 10.0.10240.19177 — fixed in 10.0.10240.19177
- Microsoft Windows 7: from 6.1.0 before 6.1.7601.25829 — fixed in 6.1.7601.25829
- Microsoft Windows 7 Service Pack 1: from 6.1.0 before 6.1.7601.25829 — fixed in 6.1.7601.25829
- Microsoft Windows 8.1: from 6.3.0 before 6.3.9600.20246 — fixed in 6.3.9600.20246
- Microsoft Windows Server 2008 R2 Service Pack 1: from 6.1.7601.0 before 6.1.7601.25829 — fixed in 6.1.7601.25829
- Microsoft Windows Server 2012: from 6.2.9200.0 before 6.2.9200.23584 — fixed in 6.2.9200.23584
- Microsoft Windows Server 2012 R2: from 6.3.9600.0 before 6.3.9600.20246 — fixed in 6.3.9600.20246
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.19177; Microsoft Windows 7 6.1.7601.25829; Microsoft Windows 7 Service Pack 1 6.1.7601.25829; Microsoft Windows 8.1 6.3.9600.20246; Microsoft Windows Server 2008 R2 Service Pack 1 6.1.7601.25829; Microsoft Windows Server 2012 6.2.9200.23584; Microsoft Windows Server 2012 R2 6.3.9600.20246. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-21899
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-21899
- https://www.zerodayinitiative.com/advisories/ZDI-22-052/
Get alerted when CVE-2022-21899 or the next vulnerability affects your stack