What’s Vulnerable › Vulnerabilities
CVE-2022-2190: Envira Gallery Lite < 1.8.4.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gallery Plugin for WordPress plugin before 1.8.4.7 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
Affected products
- smub Envira Gallery – Image Photo Gallery, Albums, Video Gallery, Slideshows & More: before 1.8.4.7 — fixed in 1.8.4.7
How to fix
Upgrade to a fixed version: smub Envira Gallery – Image Photo Gallery, Albums, Video Gallery, Slideshows & More 1.8.4.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1af4beb6-ba16-429b-acf2-43f9594f5ace
- https://wpscan.com/vulnerability/1af4beb6-ba16-429b-acf2-43f9594f5ace
Get alerted when CVE-2022-2190 or the next vulnerability affects your stack