What’s Vulnerable › Vulnerabilities
CVE-2022-21907: HTTP Protocol Stack Remote Code Execution Vulnerability
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 92.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-11 · updated 2026-06-17
Description
HTTP Protocol Stack Remote Code Execution Vulnerability
Affected products
- Microsoft Windows 10 Version 1607: 20h2, 21h1, 21h2, 1809
- Microsoft Windows 11 version 21H2: all versions
- Microsoft Windows Server: 20h2, 2022
- Microsoft Windows Server 2019: all versions
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.2452 — fixed in 10.0.17763.2452
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.1466 — fixed in 10.0.19042.1466
- Microsoft Windows 10 21H1: from 10.0.0 before 10.0.19043.1466 — fixed in 10.0.19043.1466
- Microsoft Windows 10: from 10.0.19043.0 before 10.0.19044.1466 — fixed in 10.0.19044.1466
- Microsoft Windows 11 21H2: from 10.0.0 before 10.0.22000.434 — fixed in 10.0.22000.434
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.2452 — fixed in 10.0.17763.2452
- Microsoft Windows Server 2022: from 10.0.20348.0 before 10.0.20348.469 — fixed in 10.0.20348.469
- Microsoft Windows Server version 20H2: from 10.0.0 before 10.0.19042.1466 — fixed in 10.0.19042.1466
How to fix
Upgrade to a fixed version: Microsoft Windows 10 10.0.17763.2452; Microsoft Windows 10 20H2 10.0.19042.1466; Microsoft Windows 10 21H1 10.0.19043.1466; Microsoft Windows 10 10.0.19044.1466; Microsoft Windows 11 21H2 10.0.22000.434; Microsoft Windows Server 2019 10.0.17763.2452; Microsoft Windows Server 2022 10.0.20348.469; Microsoft Windows Server version 20H2 10.0.19042.1466. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-21907
- http://packetstormsecurity.com/files/166730/Microsoft-HTTP-Protocol-Stack-Denial-Of-Service.html
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-21907
Get alerted when CVE-2022-21907 or the next vulnerability affects your stack