What’s Vulnerable › Vulnerabilities
CVE-2022-21934: Metasys Unverified Password Change
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-06 · updated 2026-06-17
- Weakness: CWE-620
Description
Under certain circumstances an authenticated user could lock other users out of the system or take over their accounts in Metasys ADS/ADX/OAS server 10 versions prior to 10.1.5 and Metasys ADS/ADX/OAS server 11 versions prior to 11.0.2.
Affected products
- Johnsoncontrols Metasys Application And Data Server: from 10.0 before 10.1.5; from 11.0 before 11.0.2 — fixed in 10.1.5, 11.0.2
- Johnsoncontrols Metasys Extended Application And Data Server: from 10.0 before 10.1.5; from 11.0 before 11.0.2 — fixed in 10.1.5, 11.0.2
- Johnsoncontrols Metasys Open Application Server: from 10.0 before 10.1.5; from 11.0 before 11.0.2 — fixed in 10.1.5, 11.0.2
How to fix
Upgrade to a fixed version: Johnsoncontrols Metasys Application And Data Server 10.1.5, 11.0.2; Johnsoncontrols Metasys Extended Application And Data Server 10.1.5, 11.0.2; Johnsoncontrols Metasys Open Application Server 10.1.5, 11.0.2. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-125-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-125-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
Get alerted when CVE-2022-21934 or the next vulnerability affects your stack