What’s Vulnerable › Vulnerabilities
CVE-2022-21938: Metasys MUI Graphics XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Under certain circumstances, a vulnerability in Metasys ADS/ADX/OAS 10 versions prior to 10.1.5 and Metasys ADS/ADX/OAS 11 versions prior to 11.0.2 could allow a user to inject malicious code into the MUI Graphics web interface.
Affected products
- Johnsoncontrols Metasys Application And Data Server: from 10.0 through 10.1.5; 11.0, 11.0.1
- Johnsoncontrols Metasys Extended Application And Data Server: from 10.0 through 10.1.5; 11.0, 11.0.1
- Johnsoncontrols Metasys Open Application Server: from 10.0 before 10.1.5; 11.0, 11.0.1 — fixed in 10.1.5
How to fix
Upgrade to a fixed version: Johnsoncontrols Metasys Open Application Server 10.1.5. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-165-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-165-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
Get alerted when CVE-2022-21938 or the next vulnerability affects your stack