What’s Vulnerable › Vulnerabilities
CVE-2022-2194: Accept Stripe Payments < 2.0.64 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Accept Stripe Payments WordPress plugin before 2.0.64 does not sanitize and escape some of its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Accept Stripe Payments: before 2.0.64 — fixed in 2.0.64
How to fix
Upgrade to a fixed version: Accept Stripe Payments 2.0.64. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ecf4b707-dea9-42d0-9ade-d788a9f97190
- https://wpscan.com/vulnerability/ecf4b707-dea9-42d0-9ade-d788a9f97190
Get alerted when CVE-2022-2194 or the next vulnerability affects your stack