What’s Vulnerable › Vulnerabilities
CVE-2022-21951: Rancher: Weave CNI password is not set if RKE template is used with CNI value overridden
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-25 · updated 2026-06-17
- Weakness: CWE-319
Description
A Cleartext Transmission of Sensitive Information vulnerability in SUSE Rancher, Rancher allows attackers on the network to read and change network data due to missing encryption of data transmitted via the network when a cluster is created from an RKE template with the CNI value overridden This issue affects: SUSE Rancher Rancher versions prior to 2.5.14; Rancher versions prior to 2.6.5.
Affected products
- SUSE Rancher: from 2.5.0 before 2.5.14; from 2.6.0 before 2.6.5 — fixed in 2.5.14, 2.6.5
How to fix
Upgrade to a fixed version: SUSE Rancher 2.5.14, 2.6.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=1199443
- https://github.com/rancher/rancher/security/advisories/GHSA-vrph-m5jj-c46c
- https://bugzilla.suse.com/show_bug.cgi?id=1199443
- https://github.com/rancher/rancher/security/advisories/GHSA-vrph-m5jj-c46c
Get alerted when CVE-2022-21951 or the next vulnerability affects your stack