What’s Vulnerable › Vulnerabilities
CVE-2022-2198: WPQA < 5.7 - Subscriber+ Private Message Disclosure via IDOR
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-639
Description
The WPQA Builder WordPress plugin before 5.7 which is a companion plugin to the Hilmer and Discy , does not check authorization before displaying private messages, allowing any logged in user to read other users private message using the message id, which can easily be brute forced.
Affected products
- WPQA Builder: before 5.7 — fixed in 5.7
How to fix
Upgrade to a fixed version: WPQA Builder 5.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/867248f2-d497-4ea8-b3f8-0f2e8aaaa2bd
- https://wpscan.com/vulnerability/867248f2-d497-4ea8-b3f8-0f2e8aaaa2bd
Get alerted when CVE-2022-2198 or the next vulnerability affects your stack