What’s Vulnerable › Vulnerabilities
CVE-2022-21997: Windows Print Spooler Elevation of Privilege Vulnerability
- Severity: low (CVSS 3.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-09 · updated 2026-06-17
- Weakness: CWE-59
Description
Windows Print Spooler Elevation of Privilege Vulnerability
Affected products
- Microsoft Windows 10 Version 1607: 20h2, 21h1, 21h2, 1607, 1809, 1909
- Microsoft Windows 11 version 21H2: all versions
- Microsoft Windows 7: sp1
- Microsoft Windows 8.1: all versions
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server: 20h2, 2022
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: all versions
- Microsoft Windows Server 2019: all versions
- Microsoft Windows 10 Version 1507: from 10.0.10240.0 before 10.0.10240.19204 — fixed in 10.0.10240.19204
- Microsoft Windows 10 1607: from 10.0.14393.0 before 10.0.14393.4946 — fixed in 10.0.14393.4946
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.2565 — fixed in 10.0.17763.2565
- Microsoft Windows 10 1909: from 10.0.0 before 10.0.18363.2094 — fixed in 10.0.18363.2094
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.1526 — fixed in 10.0.19042.1526
- Microsoft Windows 10 21H1: from 10.0.0 before 10.0.19043.1526 — fixed in 10.0.19043.1526
- Microsoft Windows 10: from 10.0.19043.0 before 10.0.19044.1526 — fixed in 10.0.19044.1526
- Microsoft Windows 11 21H2: from 10.0.0 before 10.0.22000.493 — fixed in 10.0.22000.493
- Microsoft Windows 7: from 6.1.0 before 6.1.7601.25860 — fixed in 6.1.7601.25860
- Microsoft Windows 7 Service Pack 1: from 6.1.0 before 6.1.7601.25860 — fixed in 6.1.7601.25860
- Microsoft Windows 8.1: from 6.3.0 before 6.3.9600.20269 — fixed in 6.3.9600.20269
- Microsoft Windows Server 2008 R2 Service Pack 1: from 6.1.7601.0 before 6.1.7601.25860 — fixed in 6.1.7601.25860
- Microsoft Windows Server 2008 Service Pack 2: from 6.0.6003.0 before 6.0.6003.21374 — fixed in 6.0.6003.21374
- Microsoft Windows Server 2012: from 6.2.9200.0 before 6.2.9200.23605 — fixed in 6.2.9200.23605
- Microsoft Windows Server 2012 R2: from 6.3.9600.0 before 6.3.9600.20269 — fixed in 6.3.9600.20269
- Microsoft Windows Server 2016: from 10.0.14393.0 before 10.0.14393.4946 — fixed in 10.0.14393.4946
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.2565 — fixed in 10.0.17763.2565
- Microsoft Windows Server 2022: from 10.0.20348.0 before 10.0.20348.524 — fixed in 10.0.20348.524
- Microsoft Windows Server version 20H2: from 10.0.0 before 10.0.19042.1526 — fixed in 10.0.19042.1526
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.19204; Microsoft Windows 10 1607 10.0.14393.4946; Microsoft Windows 10 10.0.17763.2565; Microsoft Windows 10 1909 10.0.18363.2094; Microsoft Windows 10 20H2 10.0.19042.1526; Microsoft Windows 10 21H1 10.0.19043.1526; Microsoft Windows 10 10.0.19044.1526; Microsoft Windows 11 21H2 10.0.22000.493; Microsoft Windows 7 6.1.7601.25860; Microsoft Windows 7 Service Pack 1 6.1.7601.25860; Microsoft Windows 8.1 6.3.9600.20269; Microsoft Windows Server 2008 R2 Service Pack 1 6.1.7601.25860. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-21997
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-21997
Get alerted when CVE-2022-21997 or the next vulnerability affects your stack