What’s Vulnerable › Vulnerabilities
CVE-2022-2206: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-26 · updated 2026-10-08
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 8.2.
Affected products
- Fedoraproject Fedora: 35, 36
- vim/vim: before 8.2.5160 — fixed in 8.2.5160
How to fix
Upgrade to a fixed version: vim/vim 8.2.5160. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/e178af5a586ea023622d460779fdcabbbfac0908
- https://huntr.dev/bounties/01d01e74-55d0-4d9e-878e-79ba599be668
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/e178af5a586ea023622d460779fdcabbbfac0908
- https://huntr.dev/bounties/01d01e74-55d0-4d9e-878e-79ba599be668
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2206 or the next vulnerability affects your stack