What’s Vulnerable › Vulnerabilities
CVE-2022-2215: GiveWP < 2.21.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The GiveWP WordPress plugin before 2.21.3 does not properly sanitise and escape the currency settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- stellarwp GiveWP – Donation Plugin and Fundraising Platform: before 2.21.3 — fixed in 2.21.3
How to fix
Upgrade to a fixed version: stellarwp GiveWP – Donation Plugin and Fundraising Platform 2.21.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/daa9b6c1-1ee1-434c-9f88-fd273b7e20bb
- https://wpscan.com/vulnerability/daa9b6c1-1ee1-434c-9f88-fd273b7e20bb
Get alerted when CVE-2022-2215 or the next vulnerability affects your stack