What’s Vulnerable › Vulnerabilities
CVE-2022-22162: Junos OS: A low privileged user can elevate their privileges to the ones of the highest privileged j-web user logged in
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-19 · updated 2026-06-17
- Weakness: CWE-209
Description
A Generation of Error Message Containing Sensitive Information vulnerability in the CLI of Juniper Networks Junos OS allows a locally authenticated attacker with low privileges to elevate these to the level of any other user logged in via J-Web at this time, potential leading to a full compromise of the device. This issue affects Juniper Networks Junos OS: All versions prior to 15.1R7-S11; 18.3 versions prior to 18.3R3-S6; 18.4 versions prior to 18.4R2-S9, 18.4R3-S10; 19.1 versions prior to 19.1R2-S3, 19.1R3-S7; 19.2 versions prior to 19.2R1-S8, 19.2R3-S4; 19.3 versions prior to 19.3R3-S4; 19.4 versions prior to 19.4R3-S6; 20.1 versions prior to 20.1R3-S2; 20.2 versions prior to 20.2R3-S3; 20.3 versions prior to 20.3R3-S1; 20.4 versions prior to 20.4R3-S1; 21.1 versions prior to 21.1R2-S1, 21.1R3; 21.2 versions prior to 21.2R1-S1, 21.2R2.
Affected products
- Juniper Junos OS: before 15.1; 15.1, 15.1-a1, 15.1-f, 15.1-f1, 15.1-f2, 15.1-f2-s1 (+197) — fixed in 15.1
How to fix
Upgrade to a fixed version: Juniper Junos OS 15.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-22162 or the next vulnerability affects your stack