What’s Vulnerable › Vulnerabilities
CVE-2022-22214: Junos OS and Junos OS Evolved: In an MPLS scenario upon receipt of a specific IPv6 packet an FPC will crash
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-20 · updated 2026-06-17
- Weakness: CWE-20
Description
An Improper Input Validation vulnerability in the Packet Forwarding Engine (PFE) of Juniper Networks Junos OS and Junos OS Evolved allows an adjacent attacker to cause a PFE crash and thereby a Denial of Service (DoS). An FPC will crash and reboot after receiving a specific transit IPv6 packet over MPLS. Continued receipt of this packet will create a sustained Denial of Service (DoS) condition. This issue does not affect systems configured for IPv4 only. This issue affects: Juniper Networks Junos OS All versions prior to 12.3R12-S21; 15.1 versions prior to 15.1R7-S10; 17.3 versions prior to 17.3R3-S12; 18.3 versions prior to 18.3R3-S6; 18.4 versions prior to 18.4R2-S9, 18.4R3-S9; 19.1 versions prior to 19.1R2-S3, 19.1R3-S7; 19.2 versions prior to 19.2R1-S7, 19.2R3-S3; 19.3 versions prior to 19.3R2-S7, 19.3R3-S4; 19.4 versions prior to 19.4R3-S5; 20.1 versions prior to 20.1R3; 20.2 versions prior to 20.2R3-S2; 20.3 versions prior to 20.3R3; 20.4 versions prior to 20.4R2-S2, 20.4R3; 21.1 versions prior to 21.1R2. Juniper Networks Junos OS Evolved All versions prior to 20.4R3-S3-EVO; 21.2 versions prior to 21.2R3-EVO; 21.3 versions prior to 21.3R2-S1-EVO, 21.3R3-EVO; 21.4 versions prior to 21.4R2-EVO.
Affected products
- Juniper Junos OS: before 12.3; 12.3, 12.3-r1, 12.3-r10, 12.3-r10-s1, 12.3-r10-s2, 12.3-r11 (+226) — fixed in 12.3
- Juniper Networks Junos OS Evolved: before 20.4; 20.4, 20.4-r1, 20.4-r1-s1, 20.4-r1-s2, 20.4-r2, 20.4-r2-s1 (+19) — fixed in 20.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 12.3; Juniper Networks Junos OS Evolved 20.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-22214 or the next vulnerability affects your stack