What’s Vulnerable › Vulnerabilities
CVE-2022-22220: Junos OS and Junos OS Evolved: Due to a race condition the rpd process can crash upon receipt of a BGP update message containing flow spec route
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-18 · updated 2026-06-17
- Weakness: CWE-367
Description
A Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Routing Protocol Daemon (rpd) of Juniper Networks Junos OS, Junos OS Evolved allows a network-based unauthenticated attacker to cause a Denial of Service (DoS). When a BGP flow route with redirect IP extended community is received, and the reachability to the next-hop of the corresponding redirect IP is flapping, the rpd process might crash. Whether the crash occurs depends on the timing of the internally processing of these two events and is outside the attackers control. Please note that this issue also affects Route-Reflectors unless 'routing-options flow firewall-install-disable' is configured. This issue affects: Juniper Networks Junos OS: 18.4 versions prior to 18.4R2-S10, 18.4R3-S10; 19.1 versions prior to 19.1R3-S7; 19.2 versions prior to 19.2R1-S8, 19.2R3-S4; 19.4 versions prior to 19.4R3-S8; 20.2 versions prior to 20.2R3-S3; 20.3 versions prior to 20.3R3-S2; 20.4 versions prior to 20.4R3; 21.1 versions prior to 21.1R2. Juniper Networks Junos OS Evolved: All versions prior to 20.4R2-EVO; 21.1-EVO versions prior to 21.1R2-EVO. This issue does not affect Juniper Networks Junos OS versions prior to 18.4R1.
Affected products
- Juniper Junos OS: before 18.4; 18.4, 18.4-r1, 18.4-r1-s1, 18.4-r1-s2, 18.4-r1-s3, 18.4-r1-s4 (+77) — fixed in 18.4
- Juniper Networks Junos OS Evolved: before 20.4; 20.4, 20.4-r1, 20.4-r1-s1, 20.4-r1-s2, 21.1, 21.1-r1 (+1) — fixed in 20.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 18.4; Juniper Networks Junos OS Evolved 20.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-22220 or the next vulnerability affects your stack